This also works with any TASCAM US-XXX.

First of all, download the old drivers from the official Tascam website.

Now, follow the instructions below, which have been copied and adapted from the original thread where explains how to make this work.

Since Sierra, MacOS does not seem to load drivers (kexts for Mac OS) that contain both a 32bit and 64bit binary and, at least for the US-600 El Capitan kext, both binaries are present.

See https://forums.developer.apple.com/thread/50380.

Luckily, code signing seems to be done on each binary when it is compiled and removing the 32bit version allows the kext to be loaded.

The following steps worked for me but obviously your mileage may vary.

Disclaimer: I accept no responsibility for what may happen to you, your computer, peripherals or anything else that may occur from following these steps. Use strictly at your own risk! Messing up with kernel extensions could prevent your machine from booting or cause crashes so make sure you have all work saved, a backup and are ready to restore/fix your machine from the recovery partition. If you are not comfortable performing the steps outlined, reverting to El Capitan is a safer option.

In the instructions below you will need to replace all instances of β€œTASCAM_US600” with whatever applies to your device.

First, open a terminal. Then, ensure that you can proceed further by checking that you see information about x86_64 and i386 from the following command:

file /Library/Extensions/TASCAM_US1641.kext/Contents/MacOS/TASCAM_US200

If so, remove the i386 binary with the following:

# First make a copy to the desktop  
sudo lipo -thin x86\_64 -output ~/Desktop/TASCAM\_US200 /Library/Extensions/TASCAM\_US200.kext/Contents/MacOS/TASCAM\_US200

This will have output a file named TASCAM_US200 to the desktop which should only have the x86_64 binary.

Remove the orignal:

sudo rm /Library/Extensions/TASCAM\_US1641.kext/Contents/MacOS/TASCAM\_US200

Copy the new binary:

sudo cp ~/Desktop/TASCAM\_US200 /Library/Extensions/TASCAM\_US200.kext/Contents/MacOS/

Try loading the new kext:

sudo kextload /Library/Extensions/TASCAM\_US200.kext

There should be no errors at this point. You can use kextstat as an additional check here. Now rebuild the kext cache:

sudo rm -rf /System/Library/Caches/com.apple.kext.caches  
sudo kextcache -prelinked-kernel /System/Library/Caches/com.apple.kext.caches/Startup/kernelcache -K /System/Library/Kernels/kernel /System/Library/Extensions

As Renato Borges mentioned in the comments, if sudo rm -rf /System/Library/Caches/com.apple.kext.caches doesn’t work for you, try with the commandsudo kextcache -e

Reboot your Mac, check the US-600 audio input is now there. If so, delete that file from your desktop.

Enjoy using your Tascam.




Thanks for your time!

I'm nahuelhds. If you like what I do, you can...